さくらインターネットのサーバーバージョンアップで起こったこと

Last edited on 2009/05/04 (月) - 23:05

さくらインターネットのサーバがバージョンアップした。

1.まず、独自インストールのPHPをCGIとして使ったWEBがエラーでアクセスできなくなった。
再度、PHPをインストールして解決。

2. Plaggerが動かなくなった。ライブラリのバージョンが整合していないため。これは、自分でインストールしたCPANを使ってPlaggerをインストールしたのだが、その時一緒に持ってきたライブラリの方を使っていたため。具体的には、DateFormat::Locale が古かった。

  • 独自インストールのCPANをUpgrade
  • ライブラリを全部 Upgrade
  • Plaggerの Gmail.pm の中で、MIME::Lite.pm の extract_addrs を使っているが、MIME::Lite.pmの中には、extract_full_addrs, extract_only_addrs しか見あたらないので、Gmail.pm の方を書き換える。

これでとりあえずOK.

追記:その後、Plaggerでいろいろ不具合が出たのと、Google Readerの使い勝手がよかったので、そちらに乗り換えました。Plaggerはもう使っていません。